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Chapter Three:
How to Produce and Manage Animation with IT
In.For.Ef (BE)

1. How to create Gif Animation
1.1 Introduction
An animation consists in a series of framed images displayed one after the other to
create the illusion of motion. Gif Animations, low-bandwidth animations which frequently
decorate Web pages, follow this principle.
An animated GIF (Graphics Interchange Format, specified as GIF89a) is a single file
that is composed of a series of individual still images, added to some timing information.
Playing these images in sequence gives the effect of a motion: an object is moved by
very small amounts between individually frames, producing the effect of motion when the
series of frames is played back at normal speed.
GIF animations are easy to make: you use common available tools, programming is not
necessary, no plug-ins are required to read them, and you use the common <IMG>
HTML tag to display them on your web page.
In this manual we’ll see how to create a GIF animation.

1.2 What you need
You'll need software to create your animations:
•

A graphics program to create the individual images; for example Photoshop,
Photopaint, or Photofiltre (freeware)...

•

A GIF animation program to convert the different images into a single GIF89a file
and add the timing information, and finally optimize it; for example Gif Movie
Gear, or Gif Animator (freeware)…

Some programs, like Photoshop/Image Ready, include both functions so you may not
need separate programs.

1.3 Frames and Timing
Animated GIF is a frame-by-frame animation, this mean that we have series of individual
still images. The animation is in fact an illusion of movement, created by the rapid
display of the sequence of images.
The number of frames by second of the animation has an impact on the smoothness of
the animation and on the size of the file. Too many frames make the file bigger and
slower to download (and require more work to make the drawings!). Few frames make
the animation appear rough.
The goal is to pick the minimum number of images necessary to accomplish the desired
motion. It’s quite difficult to anticipate the correct difference between two drawings. This
work requires a minimum of testing… Selecting the right number of frames takes some
experience and mental visualization!
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One thing to know is that the timing doesn’t have to be uniform. You can set each frame
independently, for example one frame may display for only a quarter of a second, the
next to 5 seconds. The right number of frames and timing will depend a lot on what you
are animating.
It may help to make a storyboard of the animation, consisting in a rough sketch of each
image. Don't worry about getting exactly the number of frames and the right time, you
can add or subtract frames later.
If you plan your animation not to loop, just play it one and then stop. The last frame is
what will remain on the screen. Make sure it is what you want to be seen!
You can also make an animation disappear at the end of its cycle, or somewhere in the
middle, by including a transparent image.

1.4 First, select the animation dimensions
Decide the overall width and height you want the animation to be. The largest the
dimensions are, the slowest the animation will download. So keep it as small as possible
while you maintain the effect you want to achieve.
We will create an example with Photoshop and Illustrator.
I decide that my animation will be 200x200 pixels.

1.5 Creation of the drawing
Once you’ve selected a size, draw each image of the animation as a full size image at
these same dimensions.
I draw in Photoshop the element I want to animate. This drawing will become the first
frame of my animated GIF:

Then I draw on separate layers the different steps of my animation.
In this example, I have drawn 20 images. In a first approach we could imagine that it will
be enough.
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After that, it’s time to use the animation program. In our case, it will be
“Image Ready”. A button allows that:

1.6 Steps of the animation.
In “Image Ready” you work with three windows: the Photoshop document, the Animation
palette and the Layers palette. (If the Animation palette doesn’t appear: select Window >
Animation from the main menu)
At first, your animation has only one frame, which corresponds to the visible layer. So
you have to select each layer one by one, and assign them one by one as a new frame of
the animation:
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Click on the Duplicate Current Frame icon (1) in the Animation palette to add one more
frame.
You need to let Image Ready know what layer to display for each frame of the animation.
Click on the second animation frame icon in the Animation palette to select it and then
turn the visibility of your second text layer on in the Layers palette.
Click the third animation frame icon in the Animation palette to select it and then turn
the visibility of your second and third text layers on in the Layers palette. And so on for
each layer…

Here are the pictures I used:

Next, you need to set the duration each frame will be played (4).
Choose if you want your animation to loop or not. If you don’t want it to loop, select how
long it must be played (5).
Preview your animation by clicking the Play button (6) at the bottom of the Animation
palette.
At this moment, you can add or remove frame, change the duration of each frame…

1.7 Saving your animation
From the main menu select File > Save Optimised As. This will give you the possibility to
save it as an animated GIF and/or to save it as an HTML page. For a simple animation,
just save as a GIF.
You can also select File > Export, which gives you some additional options such as
exporting as a Flash file (.swf) or a Quicktime Movie (.mov).
If you just save the file, it will be saved as a layered Photoshop file (.psd), so you can
reedit it.

2. How to create Vectorial Animation (eg. Flash)
2.1 Introduction
Before learning about vectorial animation, we have to make the difference between the
two types of 2D Graphics:
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•

Bitmap pictures: created with software like Photoshop (Adobe) or Painter
(Corel). They can also be scanned photographies.
Bitmap images are made up of pixels in a grid. Pixels are picture elements, tiny
dots of individual colour that make up what you see on your screen.

•

Vectorial pictures: created with software like Illustrator, Flash or Freehand
(Adobe)...
Vector images are made up of many individual, scalable objects. These objects
are defined by mathematical equations rather than pixels, so they are always
rendered with the highest quality. Objects may consist of lines, curves, and
shapes with editable attributes such as colour, fill, and outline. Changing the
attributes of a vector object does not affect the object itself. You can freely
change any number of object attributes without destroying the basic object. An
object can be modified not only by changing its attributes, but also by shaping
and transforming it using nodes and control handles.

In the old days of animation, in order to make something look like it was moving, an
illustrator or animator would have to draw a lot of different pictures, each one similar to
the previous, but changed in just a small way, similar to how a flip book works. (See
‘how to create an animated gif’ above.) This was known as in-betweening (later
shortened to tweening) because they had to draw all of the frames in-between the start
and end point of the animation.
In vectorial animation software you don’t have to draw all of these in-between pictures.
You only have to draw more or less the starting point of your moving object, and the
ending point. The rest is done by the program!

2.2 Basic animation
Motion tween is nothing but tweening a Symbol's movement from one position to
another.
Let’s take an example: we want to move a circle:
To implement motion tween all that you have to do is provide Flash with symbol's initial
position (first circle) and the end position (last circle). Intermediate tweening (the light
blue circles) is done by the software.
We understand now how vectorial animations files can be so light!

2.3 Guided animation
It is possible to create a simple movement by drawing a line which the symbol will follow.
This line is called ‘way’.

2.4 3D effect
It is possible, thanks to the vectorial animation, to realize a 3D effect. For that, you just
have to change the picture’s size: we delimit the starting size and the ending size and,
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here again, the software will automatically generate by interpolation the buffer pictures.
(Here, the big circle seems to be nearer that the small circle)

2.5 Morphing
We’ve just seen that we can move a picture.
We can also apply this rule of animation to several points of a simple shape. As a result,
we can make a morphing (modification of the shape)
In this example, a blue circle (starting point) will become a yellow square (ending point),
with all the transitions computed by the software!

2.6 Flash
Those vectorial animations can be created with the software ‘Flash’.
Flash animations are graphs and vectorial interactive animations mainly intended to
Website but more and more used to create some ‘little’ cartoons. These animations could
contain pictures (JPG, GIF) as well vectorial drawings, some texts or sounds.
By using vectorial picture and streaming, Flash allows the realisation of advanced and
interactive animations, while preserving the fastness of downloading and the user’s
comfort.
To read these animations, a ‘Flash Player’ is needed. It’s a free plug-in available on the

adobe website. You just have to set it up on your computer and after that, the
animations will run in the browser like an independent application. But Flash animations
are so current, that the Flash player is already present in mainly personal computers!
With Flash you can animate frame by frame or by using tweening… or by combining both
techniques.

2.7 Using of Flash
•

First in the centre of your screen is the stage. There you can add shapes or
various
other
things,
and
edit
the
graphics
of
your
animation.
All things you put on the stage is what will be displayed in your final published
animation.

•

On the left side of the Flash interface, you will see the Toolbox. This is familiar to
almost every designing program. It allows you to draw circles, squares, move
stuff around, resize shapes, and do all kinds of things…
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•

At the very top of the screen, you have the Timeline. This is where the main
action
goes
on
in
Flash.
You
can
add
frames,
layers...
Flash recognizes two different types of frames: frames and keyframe.
- Keyframes are the important frames: the frames you designate to hold distinct
images
- Frames contain whatever image you associated with the last keyframe: their
purpose is to mark time.

•

In frame by frame animations, most of the frames you create are keyframes.

•

On the right hand side of the screen, you will notice a few panels, including the
library, where all your objects are stored. Those objects can be symbols, sounds,
imported pictures…

•

At the bottom of your screen is a panel with a few tabs: the properties tab that
will contain various properties of your symbols, shapes, tweens, texts...

•

You also have the actions panel. This is where more advanced coding known as
actionscript goes on for your projects.

•

To build an animation, you can use Flash’s drawing tools to draw the content of
each frame on the stage, or you can import existing pictures; you place a picture
in each keyframe you create. You can also use the Symbols stored in the library.

•

Symbols and instances :
If you want to reuse a drawing, you should save it in Flash as a Symbol.
Symbols help to keep your animation’s finished file size down to a bare minimum.
When you create a symbol, Flash stores the piece of information for the symbol in
your document as usual. But every time you create a copy (= instance) of that
symbol, all that Flash adds to your file is the little bit of information it needs to
keep track of where you positioned that instance, its size...
The advantage of using symbol is not only the file optimization, but also the
instantaneous update: when you edit the symbol, Flash automatically updates all
the instances of that symbol on the stage! But you can also make some changes
(the height, deformations…) of each instance separately…
Flash lets you create three different types of symbols: graphic symbols, movie
clip symbols, and button symbols. A symbol can also contain other symbols,
especially movie clips, which are symbols having their own timeline,
independently from the main timeline.

Here is an example of a tutorial realized for this project, showing how to make an
animation with Flash:

http://learningame.inforef.be/tutoriaux/flash.html
You’ll see that this software is not so easy to use. If you are already familiar with other
animation or multimedia software, it will be easier, otherwise some efforts and
perseverance will be necessary.
But all the possibilities of such software will make your learning really exciting!

3. How to create Morphing Animation
3.1 Introduction
Image morphing is a visualization technique. It is often used for educational or
entertaining purposes.
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Image morphing techniques have been widely used in creating special effects for
television commercials, music videos such as Michael Jackson's “Black or White”, and
movies such as “Willow” and “Indiana Jones and the Last Crusade”.
It’s an image processing technique used to compute a transformation, that is, a
metamorphosis from one image to another. The idea is to create a sequence of
intermediate images, which when put together with the original images, represents the
transition from one image to the other.
The morphed pictures in sequence can be shown as a dynamic process like a movie. The
result can be very interesting.
In a morphing sequence between two faces, the middle picture often looks strikingly
lifelike, as a real person, but clearly it is neither the person in the first or in the second
image.
Morphing between two images achieves the best results if the images are roughly of the
same shape and colors, e.g. morphing from a tree to a cat may not result in such a good
transition as when morphing from one face to another. In this case the middle image
might look strange since it got no equivalence in the real world.
You have several morphing software, but the principle is always the same: you choose a
starting and an ending picture, and you place key dots on both source images in order to
define how the morph process will operate. With this principle you can also create
morphing with other software, as Flash…

In the following of this manual, we will see how to create a morphing animation with a
software called Fantamorph.

Note:
You can also create advanced morphing with 3d software. The principle is different: with
3d software, you cannot morph an object into a completely different object, because your
initial object and your morph target must have the same numbered vertices.

3.2 Abrasoft FantaMorph Tutorial : Starting a project
An easy way for beginners to do morph is to use ‘the New Project Wizard’:
1. On the welcome window, you can choose one task from "Open an existing project"
or "Create a new project". (If you don't want to use the wizard at startup of the
program, just check the "Don't show this wizard again". You can still launch the
wizard by choosing the File>New Project Wizard menu at any time.) To go to the
next step, just click the ‘next’ button.
2. Choose the project type you want
to create. We choose to create a
morph.

11

3.

We begin by selecting two images to morph, a beginning image and a final image.

4. Now you can crop or adjust source images if needed. (Just press "Next" button to
bypass this step.)

For a best rendering, we often have to crop one image to adjust it to the other,
a.s.o... We can make it with the program:
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Do the same with image 2.

5. Now you need to set the movie size and
length. You can choose any fixed value
offered in the Movie Size list, or you
may set it to any desired value by
choosing the button "Set Custom Size".
The default frame count value is 15, if
you want a smoother, more detailed
morph result, simply add more frames.
If you want to set the movie length by
duration, just click the "Set Duration"
button.

6. You
can
add
some
stunning effects for your
morph.

You can choose some existing feature (the program proposes some background,
foreground...), or you can create some effect yourself, by using Photoshop for
example. A mask makes a part of the picture transparent, so you can apply a
background, and it will appear. (the mask will be applied on the image and if you
apply a background, the back zone of the mask will become transparent and will
let appear the background) .

7. Now, click the "Finish" button to exit the wizard. The morph movie has been now
created.
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You can see in the first frame the original picture, in the second frame the picture
destination, and in the third frame the morph movie.
Because you haven’t added any key dots yet, the morph is simply a cross-dissolve
between the two source images.
You now have to start the most important work that is to place key dots on both source
images in order to define how the morph process will operate.

If you don't want to use the wizard, all those steps can be done manually. You can
import the source images by choosing File>Import Image 1... in the menu, then
File>Import Image 2..., or by clicking the Import Image buttons (1 and 2)

Any feature you have chosen with the wizard, you can load them manually. Let's see the
tools:
1: Import Image button
2: name of the image
3: size of the image (pixels)
4: location (x and y) of the cursor. It
corresponds to the image you see in the zoom 8
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5: size of the window. You can adjust the percentage of visualisation of the image. (you
can zoom in, zoom out, adjust...)
6: Crop Image button (open the same dialog box than with the wizzard)
7: Adjust image button (open the same dialog box than with the wizzard)

You can also choose a background, a mask... as in the project wizard. Once
you have chosen, you can display or not by clicking once, if you click twice
you can change load another feature... A right-click on the feature you have
loaded and it disappear.

Notice: For an optimal result, you'd better optimize the images first in Photoshop.
Remember that the most important element in producing morphs, whatever the software
you’re using, is to place key dots on both source images in order to define how the
morph process will operate. So let's place dots.

3.3 Adding dots.
The principle is to place key dots on both source images in order to define how the
morph process will operate.
Let's see the tools:

1: Edit tools: You can select dots, add a key dot (+); delete a dey dot ()... Notice that you can also delete a dot with any tool selected by rightclicking on the dot. So, most of the time you have the (+) tool selected.
With it you can add a new one by clicking anywhere on the image, you can
delete and you can move dots.
2: Auto add corresponding dot: with this tool selected, when you add a
dot in an image, another appears automatically on the other image. If this
option not selected, you have to click on the other image to place it. If this
option is checked, for each click on either image, a corresponding dot will
appear automatically on the opposite image. Generally, the automatically
added dot is not located at the correct position, so you have to drag it to
the position corresponding to the partner dot's location.
3: Auto Jump to Corresponding Dot: If this option is checked, when you
added a dot on an image, the mouse cursor will automatically jump to
corresponding position on the opposite image.
4: view tools: Adjust Viewport; zoom in and zoom out.
5: Zoom/Pan Sources Simultaneously: When you zoom/pan any one of the two source
images, the program will zoom/pan the other one simultaneously.
6: Zoom/Pan Preview Simultaneously: When you zoom/pan any one of the two source
images,
the
program
will
zoom/pan
the
preview
simultaneously
Notice that in most cases, it is recommended to make both the options checked. In this
way all windows can be located at the same position automatically.
7: The Magnifier: magnifies the area under and around the mouse cursor when you are
working within the source or target image. This enables you to have good precision on
delicate operation such as adjustment without having to zoom in and out continuously.
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Let's begin with our photos:
•

This time to work with Photoshop
retouched photos: cut out faces with
transparent background (the background
will be loaded as an external file).

•
As we’ve said, it's good to place dots on
the major elements of a morphing image;
in this example, the major elements are
eyes, nose, mouth... (NB: In FantaMorph
Deluxe, a "Face Locator" button will
appear on this page. It helps you to
automatically place key dots on images of
human face.)

Let's put keys on those elements:
•

Confirm that the edit tool Add Dot + is selected, then move mouse to the corner
of the eye.

•

Click the left mouse button. A dot will appear on image 1, and a corresponding dot
will appear on image 2. Move the corresponding dot to a suitable position.
The Magnifier (7) will help you. If you don't see where the corresponding dot is
on the other image, just rollover the dot and it will appear in white on the other
image.
•

Add other dots for the remaining
corners of both eyes. The more
dots you place on the elements of
your image, the better your morph
result will be, so feel free to
continue adding dots to further
define
the
eye
shapes.
Notice that the movie morph
will change accordingly as each
key dot is created or moved!

•

You can help yourself with the preview tools. Notice that with this software, you
don't have to make any render to visualize your final morph, you will immediately
see it...
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1.

You can choose the Movie Size. The default value is the same size as Image 1.
You can choose any fixed value offered in the popup menu, but as I said it's
better to work witimages which have already the same size...

2.

You can adjust the percentage of visualisation of the morph. (you can zoom in,
zoom out, adjust...)

3.

The most important control is the Preview Slider Bar. Each morph frame from
the first to the last can be previewed easily by simply dragging the Preview
Slider. For example, if you position the slider at the centre, you will preview the
frame representing the middle of the morph. If you position the slider all the way
to the right, you will preview the final frame of the morph, which is essentially
Image 2.

4.

The Current Frame box

5.

The Movie Frames box
If you want a smoother, more detailed morph result, simply add more frames:
click, input a new frame count and press the Enter key; or click the Movie
Frames Spin Button to increase or decrease the frame count by one

6.

Auto loop: the morph will repeatedly play until you press the Pause

7.

Auto play all (used with sequences)

8.

Auto Reverse: make the morph cycle from start to end, then reverse from end to
start.

9.

Auto Switch (used with sequences)

10. This is the control panel: Play/Pause button, previous frame, next frame, jump
to the first and to the last frame buttons.
•

Do the same with the eyebrows, the mouse, the nose etc. And you will see the
movie morph little by little become nicer.
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•

Then the contour of the face, the shoulders, the hairs...

•

Let's see the result:

•

Now you have to export your movie!

3.4 Exporting the movie
You can export only some frame, or the whole morphing.
Choose File\Export Current Frame... or File\Export movie... menu, or use the toolbar
beside the preview box:
1 Export Current Frame
2 Export Movie: In most cases, movie is what you’ll choose
3 Export Options
•

To export a frame, drag the preview slider to the position indicating the image
you want to export, and choose a name and an image format.

•

To export the movie:
First choose one of the 7 export methods available: Image Sequence, AVI Movie,
Animated GIF, Flash Movie, Web Page, Screen Saver and Standalone EXE. Then,
adjust the export parameters by clicking the Export Options button.
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In the Movie Export Window, click on the format you've chosen, and click the
"Export" button to start export...

... And "Open" to see your movie...
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